White Spots on my New York Primal

  • shavedhobbit
  • Topic Author
  • Away
  • Fresh Boarder
  • Fresh Boarder
More
5 days 18 hours ago #14514 by shavedhobbit
White Spots on my New York Primal was created by shavedhobbit
Hi Ron and everyone!

I have successfully finish my first dry age with Umai. A 45 day dry age ribeye choice from Costco. It turned out awesome!

See screenshot below.
www.flickr.com/photos/145130990@N08/shares/A7xx3N

I have started my second project which is a New York Strip Primal choice from Costco. It is now 3 weeks in and I am noticing small white spots that look like mold? Can the community please look over the pics and advise if I should be worried? I have done the smell test and so far everything smells fine. I am not sure if these white spots are mold or not. The bag definitely became a bit more loose than my first project. I also compared the pics to my first project and noticed more white spots than prior.

See screenshot of white spots below.
www.flickr.com/photos/145130990@N08/shares/PA9DnW


Should I be worried or leave it alone for the full dry age time? I am planning to dry age 60 days with this New York Primal.

Please Log in or Create an account to join the conversation.

  • RRP
  • RRP's Avatar
  • Away
  • Moderator
  • Moderator
  • retired dude
More
5 days 3 hours ago #14515 by RRP
Replied by RRP on topic White Spots on my New York Primal
Thanks for your epilogue about your rib eye!

Yes, those white spots appear to me as being mold spores. Please tell me if the meat was in a cry-o-vac bag and how you bagged it. There is a definite procedure to follow as outlined in the Q & A section.
Ron

Please Log in or Create an account to join the conversation.

  • shavedhobbit
  • Topic Author
  • Away
  • Fresh Boarder
  • Fresh Boarder
More
5 days 2 hours ago #14516 by shavedhobbit
Replied by shavedhobbit on topic White Spots on my New York Primal
Hi Ron,

I followed the standard procedure, the meat came straight from Costco cryobagged. I did the clean transfer method which is cut open the end drain some liquid out then I stood it up and put the Umai bag over it and then flipped it. I used my foodsaver 2000 and helped massage as much air out as I could. I also double sealed in all areas just in case.

In this situation, what are my options? Should i let it ride and hope the mold won't get inside the meat? Its been 3 weeks. Should I open up the bag and wipe it down with vinegar and rebag with another Umai bag?

Thanks for mentioning there is a definite procedure in the Q&A section, I will go look for it.

Please Log in or Create an account to join the conversation.

  • shavedhobbit
  • Topic Author
  • Away
  • Fresh Boarder
  • Fresh Boarder
More
5 days 2 hours ago #14517 by shavedhobbit
Replied by shavedhobbit on topic White Spots on my New York Primal
Hi Ron, I was looking for the definite procedure in the Q&A section, I couldn't find it. Did you mean the FAQ section? Could you please direct me to the definite procedure on how to handle my situation? Thanks!

Please Log in or Create an account to join the conversation.

  • RRP
  • RRP's Avatar
  • Away
  • Moderator
  • Moderator
  • retired dude
More
5 days 1 hour ago #14519 by RRP
Replied by RRP on topic White Spots on my New York Primal
You did it properly. Now as for that possible mold I would let it ride out without re-bagging. Mold such as that is on the surface only and does not "enter" the meat. Then after aging you will skim off that hard outer crust.

Heres the list I meant when I said Q & A.
www.drybagsteak.com/drybag-steak-faq.php#8
Ron

Please Log in or Create an account to join the conversation.

  • shavedhobbit
  • Topic Author
  • Away
  • Fresh Boarder
  • Fresh Boarder
More
5 days 18 minutes ago #14522 by shavedhobbit
Replied by shavedhobbit on topic White Spots on my New York Primal
Hi Ron,

Thanks for your advice. I will ride it out and trim carefully. I appreciate you sharing your wisdom and experience as always!

Please Log in or Create an account to join the conversation.

Moderators: RRP
Time to create page: 0.278 seconds
Powered by Kunena Forum