White spots on 30 day aged brisket

  • dryage1264
  • Topic Author
  • Away
  • Fresh Boarder
  • Fresh Boarder
More
3 weeks 3 days ago #15809 by dryage1264
White spots on 30 day aged brisket was created by dryage1264
I’m 30 days in on this brisket. Had a little trouble getting the bag sealed initially but eventually got a good seal on it. Currently, there is a little bit of white spottiness on the brisket. Overall it smells fine and like Ron has said, let your nose be your guide. So I am assuming it is fine, but would like some guidance. I read somewhere it might just be the salt coming out of the meat? Any help is much appreciated.

Pictures are attached.
https://drive.google.com/drive/folders/1XADTdPhKqfcfOWHPEhjYDOX-AFjMv3JJ

Please Log in or Create an account to join the conversation.

  • RRP
  • RRP's Avatar
  • Away
  • Moderator
  • Moderator
  • retired dude
More
3 weeks 3 days ago #15810 by RRP
Replied by RRP on topic White spots on 30 day aged brisket
Even if it is some mold spores they are only on the surface and you will be trimming the hard outer surface off anyway. The only exception is if by chance that brisket had been blade tenderized then that's a whole new ballgame!
Ron

Please Log in or Create an account to join the conversation.

  • dryage1264
  • Topic Author
  • Away
  • Fresh Boarder
  • Fresh Boarder
More
3 weeks 3 days ago #15811 by dryage1264
Replied by dryage1264 on topic White spots on 30 day aged brisket
Thanks Ron! Nope, it’s a Costco brisket fresh out of the cryovac. Looking forward to eating it next weekend.

Please Log in or Create an account to join the conversation.

  • RRP
  • RRP's Avatar
  • Away
  • Moderator
  • Moderator
  • retired dude
More
3 weeks 3 days ago #15812 by RRP
Replied by RRP on topic White spots on 30 day aged brisket
GREAT! BTW you do have to watch COSTCO though they are blade tenderizer happy so you must buy while still sealed so just don't assume!
Ron

Please Log in or Create an account to join the conversation.

Moderators: RRP
Time to create page: 0.276 seconds
Powered by Kunena Forum