Trouble getting the bag to bond

  • Sal
  • Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
4 weeks 1 day ago #15915 by Sal
Trouble getting the bag to bond was created by Sal
Hi,
I sealed a porterhouse 7 days ago and had trouble getting it to bond properly, especially on the sealed end. The sides seem to be OK, but not the ends. No bonding at all. There seems to be more air in the bag than I usually experience. I'd say I'm right around 75% bonded. Should I try to re-vacuum the bag at this point, abort, or something else? I am contemplating standing it up on the sealed end to see if that helps.
Don't want to throw out a $200 piece of meat.

Please Log in or Create an account to join the conversation.

  • RRP
  • RRP's Avatar
  • Away
  • Moderator
  • Moderator
  • retired dude
More
4 weeks 20 hours ago #15917 by RRP
Replied by RRP on topic Trouble getting the bag to bond
Sal,
75% is fine. NO NEED - NOR would it behoove you to try to re-bag it. But if it still bothers you then make a small puncture in an end and merely squeeze out the air then tape over the hole.
Ron
The following user(s) said Thank You: Sal

Please Log in or Create an account to join the conversation.

  • Sal
  • Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
3 weeks 5 days ago - 3 weeks 5 days ago #15919 by Sal
Replied by Sal on topic Trouble getting the bag to bond
Thanks Ron. I think because it’s a porterhouse, it’s not what I usually experience. Maybe the triangular shape makes it difficult to get more bonding than usual.

I haven’t noticed as much pellicule as I would have had with a rib eye after 10 days, but I suppose that’s also due to the cut.

Pics for reference.

photos.app.goo.gl/ws8tHj3MZ3SogZGS6
Last edit: 3 weeks 5 days ago by Sal.

Please Log in or Create an account to join the conversation.

Moderators: RRP
Time to create page: 0.282 seconds
Powered by Kunena Forum